Slow response time across all platforms

Incident Report for AccuLynx

Resolved

We have resolved the performance issue and monitoring performance now.
Posted May 24, 2024 - 09:44 CDT

Investigating

We are currently investigating this issue.
Posted May 24, 2024 - 09:05 CDT
This incident affected: Web Application, Mobile Application, API, and Email Sending and Receiving.