Emails Not Sending

Incident Report for AccuLynx

Resolved

This incident has been resolved.
Posted Oct 22, 2024 - 09:18 CDT

Update

We are continuing to investigate this issue.
Posted Oct 22, 2024 - 06:53 CDT

Investigating

Emails are currently not sending. We are working to resolve this.
Posted Oct 22, 2024 - 06:52 CDT
This incident affected: Email Sending and Receiving.